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Introduction
The Best Modules BMD11M134 is a 4-digit digital tube module, which uses the I2C communication 
method. This document provides the description of the BMD11M134 Arduino Lib function and how 
to install the Arduino Lib. The example demonstrates the function of displaying characters by using 
digital tubes.

Arduino Lib Functions
Arduino Lib Name: BMD11M134 Lib Version: V1.0.21

Constructor & Initialisation

1

BMD11M134(TwoWire *theWire=&Wire)
Description Constructor
Parameter *theWire: Select the I2C interface

Return Value —
Note —

2

void begin()
Description Module initialisation
Parameter —

Return Value void
Note —

Performance Functions

3

uint8_t getNumber()
Description Get the cascade module number
Parameter —

Return Value Cascade module number
Note —

4

uint8_t clear()
Description Clear the display of the specified module
Parameter —

Return Value

Execution result:
0x00: Succeeded 
0x40: Checksum wrong 
0x80: Instruction is not supported
0xA0: Cascade slaves do not respond

Note —

5

uint8_t decimalOnSingle(uint8_t displayNumber)
Description Turn on the specified module’s decimal point
Parameter displayNumber: Module ID

Return Value

Execution result:
0x00: Succeeded
0x40: Checksum wrong 
0x80: Instruction is not supported
0xA0: Cascade slaves do not respond

Note ID: Refer to the multi-board cascade section in the relevant module user guide
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6

uint8_t decimalOffSingle(uint8_t displayNumber)
Description Turn off the specified module’s decimal point
Parameter displayNumber: Module ID

Return Value

Execution result:
0x00: Succeeded
0x40: Checksum wrong 
0x80: Instruction is not supported
0xA0: Cascade slaves do not respond

Note ID: Refer to the multi-board cascade section in the relevant module user guide

7

uint8_t decimalOn()
Description Turn on all the cascade modules’ decimal points
Parameter —

Return Value

Execution result:
0x00: Succeeded
0x40: Checksum wrong
0x80: Instruction is not supported
0xA0: Cascade slaves do not respond

Note —

8

uint8_t decimalOff()
Description Turn off all the cascade modules’ decimal points
Parameter —

Return Value

Execution result:
0x00: Succeeded
0x40: Checksum wrong
0x80: Instruction is not supported
0xA0: Cascade slaves do not respond

Note —

9

uint8_t colonOnSingle(uint8_t displayNumber)
Description Turn on the specified module’s colon
Parameter displayNumber: Module ID

Return Value

Execution result:
0x00: Succeeded
0x40: Checksum wrong
0x80: Instruction is not supported
0xA0: Cascade slaves do not respond

Note ID: Refer to the multi-board cascade section in the relevant module user guide

10

uint8_t colonOffSingle(uint8_t displayNumber)
Description Turn off the specified cascade module’s colon
Parameter displayNumber: Module ID

Return Value

Execution result:
0x00: Succeeded
0x40: Checksum wrong
0x80: Instruction is not supported
0xA0: Cascade slaves do not respond

Note ID: Refer to the multi-board cascade section in the relevant module user guide

11

uint8_t colonOn()
Description Turn on all the cascade modules’ colons
Parameter —

Return Value

Execution result:
0x00: Succeeded
0x40: Checksum wrong
0x80: Instruction is not supported
0xA0: Cascade slaves do not respond

Note —
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12

uint8_t colonOff()
Description Turn off all the cascade modules’ colons
Parameter —

Return Value

Execution result:
0x00: Succeeded
0x40: Checksum wrong
0x80: Instruction is not supported
0xA0: Cascade slaves do not respond

Note —

13

uint8_t shiftRight(uint8_t shiftAmt=1)
Description Make the module’s string shift right
Parameter shiftAmt: Shift amount

Return Value

Execution result:
0x00: Succeeded
0x40: Checksum wrong 
0x80: Instruction is not supported
0xA0: Cascade slaves do not respond

Note —

14

uint8_t shitfLeft(uint8_t shiftAmt=1)
Description Make the module’s string shift left
Parameter shiftAmt: Shift amount

Return Value

Execution result:
0x00: Succeeded
0x40: Checksum wrong 
0x80: Instruction is not supported
0xA0: Cascade slaves do not respond

Note —

15

void printChar(uint8_t displayNumber, uint8_t displayChar, uint8_t digit)
Description Make the specified module’s digital tube digit display a character

Parameter
displayNumber: Module ID
displayChar:Display the ASCII code corresponding to the character
digit: Digital tube digit, ranging from 0 to 3(Note)

Return Value void

Note ID: Refer to the multi-board cascade section in the relevant module user guide
After the updateDisplay() is executed, the character can be displayed.

16

uint8_t updateDisplay()
Description Update the specified module’s digital tube display
Parameter —

Return Value

Execution result:
0x00: Succeeded
0x40: Checksum wrong
0x80: Instruction is not supported
0xA0: Cascade slaves do not respond

Note —

17

uint8_t printStr(char buffer[])
Description Make the module display a string 
Parameter buffer[]: An array which is used to store the characters to be displayed

Return Value

Execution result:
0x00: Succeeded
0x40: Checksum wrong
0x80: Instruction is not supported
0xA0: Cascade slaves do not respond

Note The input string length should be no more than 4×cascade module number
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18

uint8_t setBrightness(uint8_t displayNumber, uint8_t brightness)
Description Set the module brightness 

Parameter

displayNumber: Module ID
brightness: Brightness level parameter, ranging from 0 to 2  
0: Level 1 (Darker)
  1: Level 2
  2: Level 3 (Lighter)

Return Value

Execution result:
0x00: Succeeded
0x40: Checksum wrong
0x80: Instruction is not supported
0xA0: Cascade slaves do not respond

Note ID: Refer to the multi-board cascade section in the relevant module user guide  

19

uint16_t getFWVer(uint8_t displayNumber)
Description Obtain the module firmware version  
Parameter displayNumber: Module ID

Return Value Module firmware version
Note ID: Refer to the multi-board cascade section in the relevant module user guide  

Note: One module has four digital tube digits(D1~D4) and the digits are 0~3 from left to right

D1 D2 D3 D4

Arduino Lib Download and Installation
BMD11M134 Library: Refer to the following two methods to install the BMD11M134 Arduino 
Library.

Method 1: Search for installation
Arduino IDE→Sketch→Include Library→Manage Libraries...→Search BMD11M134→Install
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Method 1

Search for Installation Step 1

BMD11M134

Search for Installation Step 2

Method 2: Download the .ZIP library before adding it
Download the Arduino example (BMD11M134 Library) under the DOCUMENTS menu from the 
Best Modules website (https://www.bestmodulescorp.com/bmd11m134.html).

Add .ZIP library: Arduino IDE→Sketch→Include Library→Add .ZIP Library...

Method 2
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Arduino Example

Example1: printString

Physical Connection Diagram

Function: Obtain the cascade module number and display it on the serial monitor. In addition, 
display the string “HOLTBEST” on the 4-digit digital tube modules.

1. Open the example: Arduino IDE→File→Examples→Select Lib (BMD11M134)→Select example 
(printString)

2. Example Description:

a. Create the object & Module initialisation

#include "BMD11M134.h"
BMD11M134 Display(&Wire);
char cdata[100];  // An array which is used to store the information 
                  // to be displayed
String sdata;     // A string which is used to store the information 
                  // to be displayed
void setup()
{
  Serial.begin(9600);  // Initialise the serial monitor
  Display.begin();     // Initialise the module

b. Obtain the cascade module number and display it on the serial monitor. In addition, display the 
string “HOLTBEST” on the 4-digit digital tube modules.

  Serial.print(Display.getNumber()); // Display the connected module 
                                     // number on the serial monitor
  Serial.print(" modules are ");
  Serial.println("Connected!");
  sdata="HOLTBEST";                  // A string to be displayed
  sdata.toCharArray(cdata,9);        // Transform the string format 
                                     // into the array format
  Display.printStr(cdata);           // Display the information on the
                                     // 4-digit digital tube modules
}
void loop()
{
}
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3. Open the serial monitor and select the baud rate to be 9600. The serial monitor will display the 
data as follows.

Example2: printChar

Physical Connection Diagram

Function: Display the “HOLTBEST” on the 4-digit digital tube modules.

1. Open the example: Arduino IDE→File→Examples→Select Lib (BMD11M134)→Select example 
(printChar) 

2. Example Description:

a. Create the object & Module initialisation

#include "BMD11M134.h"
 BMD11M134 Display(&Wire);
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void setup()
{
  Serial.begin(9600);      // Initialise the serial monitor
  Display.begin();        // Initialise the module
}

b. Display the “HOLTBEST” on the 4-digit digital tube modules.

void loop()
{
  Display.printChar(1, 'H', 0);
  Display.printChar(1, 'O', 1);
  Display.printChar(1, 'L', 2);
  Display.printChar(1, 'T', 3);
  Display.printChar(2, 'B', 0);
  Display.printChar(2, 'E', 1);
  Display.printChar(2, 'S', 2);
  Display.printChar(2, 'T', 3);  
  Display.updateDisplay();
}

3.  Display of the digital tube:

Example3: shift

Physical Connection Diagram

Function: Display the “BEST” on the digital tube and right shift it before left shifting it.

1. Open the example: Arduino IDE→File→Examples→Select Lib (BMD11M134)→Select example 
(shift)

2. Example Description:

a. Create the object & Module initialisation

#include "BMD11M134.h"
 BMD11M134 Display(&Wire);
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char cdata[100];       //An array which is used to store the
                       //information to be displayed
String sdata;          //A string which is used to store the
                       //information to be displayed
void setup()
{
  Serial.begin(9600);      // Initialise the serial monitor
  Display.begin();        // Initialise the module
}

b. Display the “Best” on the digital tubes and right shift it before left shifting it.

void loop()
{
  sdata="BEST";
  sdata.toCharArray(cdata,5);
  Display.printStr(cdata);          //Display the "BEST"
  for(uint8_t i = 0; i < 4; i++)
  {
    delay(300);
    Display.shiftRight();         //Right shift the "BEST"
  }
  delay(1000);
  sdata="BEST";
  sdata.toCharArray(cdata,5);
  Display.printStr(cdata);          //Display the "BEST"
  for(uint8_t i = 0; i < 4; i++)
  {
    delay(300);
    Display.shiftLeft();          //Left shift the “BEST”
  }
  delay(1000);
}

3.  The following two steps will be executed circularly when this example runs: First, display the 
“Best” and right shift one digit every 300ms until all the digits have been shifted. Then, redisplay 
the “Best” and left shift one digit every 300ms until all the digits have been shifted.



Rev. 1.20 12 September 05, 2024 Rev. 1.20 PB September 05, 2024

BMD11M134 
4-Digit Digital Tube Module

BMD11M134 
4-Digit Digital Tube Module

Copyright© 2023 by BEST MODULES CORP. All Rights Reserved.

The information provided in this document has been produced with reasonable 
care and attention before publication, however, BEST MODULES does not 
guarantee that the information is completely accurate. The information contained in 
this publication is provided for reference only and may be superseded by updates. 
BEST MODULES disclaims any expressed, implied or statutory warranties, 
including but not limited to suitability for commercialization, satisfactory quality, 
specifications, characteristics, functions, fitness for a particular purpose, and non-
infringement of any third-party’s rights. BEST MODULES disclaims all liability 
arising from the information and its application. In addition, BEST MODULES 
does not recommend the use of BEST MODULES’ products where there is a risk 
of personal hazard due to malfunction or other reasons. BEST MODULES hereby 
declares that it does not authorise the use of these products in life-saving, life-
sustaining or safety critical components. Any use of BEST MODULES’ products 
in life-saving/sustaining or safety applications is entirely at the buyer’s risk, and 
the buyer agrees to defend, indemnify and hold BEST MODULES harmless from 
any damages, claims, suits, or expenses resulting from such use. The information 
provided in this document, including but not limited to the content, data, examples, 
materials, graphs, and trademarks, is the intellectual property of BEST MODULES 
(and its licensors, where applicable) and is protected by copyright law and other 
intellectual property laws. No license, express or implied, to any intellectual 
property right, is granted by BEST MODULES herein. BEST MODULES reserves 
the right to revise the information described in the document at any time without 
prior notice. For the latest information, please contact us.
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